Forgot your password?
typodupeerror
Open Source KDE

Qt Upgrades From LGPLv2.1 to LGPLv3 117

Posted by Unknown Lamer
from the who-doesn't-like-freedom-zero dept.
Digia has announced that existing Qt modules will now be covered under the LGPLv3 in addition to the LGPLv2.1, GPLv3, and the enterprise (proprietary) license. New modules will be dropping LGPLv2.1 and GPLv3+ and be released under the LGPLv3 and GPLv2+ instead. This should be a good move: new Qt modules will be Apache license compatible, LGPLv3 code can trivially be converted to GPLv3, and Digia is even releasing a few modules it intended to make proprietary as Free Software. The KDE Free Qt Foundation is on board. The move was made because of device vendors exploiting a loophole in the GPLv2/LGPLv2.1 that denied users the right to modify Qt or write their own applications. Digia has some self-interest as well, since those vendors were exploiting the tivoization loophole to avoid buying enterprise licenses. From the announcement: We also consider locked-down consumer devices using the LGPL’ed version of Qt to be harmful for the Qt ecosystem. ... Because of this, we are now adding LGPL v3 as a licensing option to Qt 5.4 in addition to LGPL v2.1. All modules that are part of Qt 5.3 are currently released under LGPL v2.1, GPL v3 and the commercial license. Starting with Qt 5.4, they will be released under LGPL v2.1, LGPL v3 and the commercial license. ... In Qt 5.4, the new Qt WebEngine module will be released under LGPL v3 in the open source version and under a LGPLv2.1/commercial combination for Qt Enterprise customers. ...

Adding LGPLv3 will also allow us to release a few other add-ons that Digia before intended to make available solely under the enterprise license. ... The first module, called Qt Canvas3D, will give us full WebGL support inside Qt Quick. ... The second module is a lightweight WebView module ... There is a final add-on that will get released under LGPL v3. This module will give native look and feel to the Qt Quick Controls on Android. This module can’t be released under LGPL v2.1, as it has to use code that is licensed under Apache 2.0, a license that is incompatible with LGPL v2.1, but compatible with LGPL v3.
This discussion has been archived. No new comments can be posted.

Qt Upgrades From LGPLv2.1 to LGPLv3

Comments Filter:

"I have more information in one place than anybody in the world." -- Jerry Pournelle, an absurd notion, apparently about the BIX BBS

Working...